ActivMan

Quick Start Guide

Version 3.0

This guide is designed for those that would like to get ActivMan up-and-running quickly. It contains
step-by-step procedures for performing the most common tasks when first starting out using the
application.

1. Installing and Launching ActivMan (main application)
a) For any edition of ActivMan, you must install the main application. Install the main
application in a desired location. If you are installing the client-server edition then you will
need to install this to the same folder. If you are upgrading from a previous version then you
MUST install it to the same location so that the templates and configuration files are reused.
b) On running ActivMan for the first time you will receive the following message:

c) Click ‘OK’ and the main window will appear.
d) To enter your valid product key select ‘Options’ from the ‘Edit’ menu.
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e) Select the ‘License’ tab.

f) Enter the company name you used to register ActivMan.
g) Click ‘...’ button and enter your product key.

h) Once entered click ‘OK’.
i) If the product key is valid you will receive the following message:

If the product key is invalid the product key box will appear read and the expires box will
state “INVALID”.
j) Click ‘OK’ on the message box.
k) Click ‘OK’ on the options dialog.
l) Restart the application for the product key to take effect.
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2. Setting initial configuration options
When ActiMan starts for the first time you will need to set various options for your installation.
a) Select ‘Options’ from the ‘Edit’ menu.

b) At this stage you will not be able to select a default server as you have not created any. But
when you have created a connection to your AD server then you will be able to select this
server, and selecting ‘Yes’ for ‘Connect to default server on startup’, to automatically to
connect to it when loading the application.
c) Select the “installation type” for your network. In most cases this will simply be a ‘single
domain in a single site’. Although you some circumstances you will may have a single
domain across multiple sites. Selecting the correct option here is crucial to the operation of
ActivMan as different operations will occur depending on the ‘installation type’.
d) When you have existing users you will need to populate the AD user accounts with the MIS
ID so that ActivMan can link the user accounts to the MIS users. This is achieved by running
an extraction from your MIS and generating each user account based on the selected
template. If a conflict is found, and the ID in the user account is empty, then the ‘Match By’
option is used to determine if the accounts are a match. If they are a match then the ID field
of the user account is populated with the ID from your MIS.
e) During the import process you will have the option to create teaching groups based on the
teaching sets extracted from your MIS. You can now specify the type of groups that are
created by changing the ‘Create Teaching Groups As’ option.
f) ActivMan links MIS users and AD user accounts by storing an MIS ID in the AD user account.
By default ActivMan will store the MIS ID in the ‘employeeID’ field but this can be changed if
required by changing the ‘User ID Field’ option.
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g) Select the ‘Importing’ tab.

h) When performing an import ActivMan will detect users from your MIS which have been
flagged as “left”. These options can be set so ActivMan knows what to do with the “left”
students. If you are running single domain across multiple sites then you will probably want
to select ‘Yes’ for ‘Remove user from member groups’.
i) Select the ‘Years’ tab.
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j)

Enter any year groups which are specific to your installation, e.g. nursery, reception, etc. But
remember to enter the year group and NOT the name, e.g. “Nu”, “Re”, etc. You must also
enter one per line, and each line but be exactly as represented in your MIS. If there are any
differences, e.g. spaces or commas, then ActivMan will not be able to match it.
k) Select the ‘MISs’ tab.

l)

Here you will need to create the entry for your MIS. Enter a name and the path to the MIS
DLL.
m) Click ‘OK’ to save the changes.

3. Connecting to your Active Directory server/domain
a) Either:
i.
Select ‘Servers’ from the list on the left and right click in the Servers list, and click
‘New Connection’.
ii.
Right click ‘Servers’ from the list on the left and select ‘New Server’.

ActivMan v3.0 Quick Start Guide

© Copyright 2009 - 2012 ANB Software Ltd

19th August 2012

iii.

Select ‘Connection’ from the ‘New’ menu in the ‘File’ menu.

b) Enter a domain controller in the ‘Server’ box. This can either be the IP address or the name
of the server. It is advisable when entering the name to enter the full name, including the
domain, e.g. myserver.mydomain.local
c) Enter the root of the AD structure to which you would like to start browsing from. For
example, your absolute root will be the domain itself, e.g. “dc=mydomain,dc=local”. If you
wish to have ‘Users’ as your root then you would enter “cn=users,dc=mydomain,dc=local”.
d) Enter the username and password of a user that has access to the AD. This username and
password will be used for all AD operations. You MUST enter the full AD path to the user,
e.g. “cn=administrator,cn=users,dc=mydomain,dc=local”.
e) Select the authentication type to connect to the server.
f) If you are running a single domain across multiple sites then you will need to select the
‘Sites’ tab.
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g) If your AD structure has an OU for each site then you will need to specify which OU belongs
which site. Therefore, you must also specify which OU belongs to “this” site.
h) Now enter the name, OU, and home directory location for each site in your domain. This is
required if users are moving between sites regularly. When a user “leaves” a site they will
be marked as “left” by their MIS. So ActivMan will need to be configured to disable the user
account and remove all member groups. Then ActivMan on the new site will detect the user
has arrived their by their MIS and will need to move the account to “this” sites OU.
ActivMan will also move any user data from their old site to the new site, if the home
directory path is specified. ActivMan will also need to have permission to access this path.
i) Click ‘OK’ when finished.
j) You will be asked if you would like to connect to this new server. Select ‘Yes’.

4. Setting your default Active Directory server
Setting the default server will force the application to connect to this server every time the
application loads. To do this, follow these steps:
a) Select ‘Options’ from the ‘Edit’ menu.
b) On the ‘General’ tab, select the default server.
c) If you wish to connect to this server every time the application starts then select ‘Yes’ for
‘Connect to default server on startup’
d) Click ‘OK’ for the settings to be saved.

5. Adding your MIS server
Adding your MIS server will allow you to extract data from your MIS in order to create
corresponding user accounts. To do this, follow these steps:
a) Either:
i.
Select ‘Databases’ from the list on the left and right click in the Databases list, and
click ‘New Database’.
ii.
Right click ‘Databases’ from the list on the left and select ‘New Database’.
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iii.

Select ‘Database’ from the ‘New’ menu in the ‘File’ menu.

b) Enter the SQL server name/instance of your MIS server.
c) Select the database type.
d) Enter the database name or click ‘Find’. ‘Find’ will attempt to connect to the specified server
and “find” the correct database, but this will always use the first database it finds that has
certain features of the database type. Should you have backup databases on this server
then they may be detected instead of the live one, so please be careful.
e) Enter the SQL username and password in order to connect to the database. If you wish to
use Windows Authentication then leave both of these field blank and the current user will
be used. The current user is always the current user executing the software at the time.
f) You can click ‘Test’ to “test” the connection.
g) Click ‘OK’ to save the new connection.

6. Creating a template
To ease the administration of different types of user, i.e. Year 7 students, office staff, teachers,
etc, you ideally need to create a template for each different type of people. These templates will
be used to import users from your MIS or create new users manually. To do this, follow these
steps:
a) Ensure you are connected to a server.
b) Either:
i.
Select ‘Templates’ from the list on the left and right click in the Templates list, and
click ‘New Template’.
ii.
Right click ‘Templates’ from the list on the left and select ‘New Template’.
iii.
Select ‘Template’ from the ‘New’ menu in the ‘File’ menu.
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iv.

Click ‘New Template’ from the toolbar.

c) On the ‘General’ tab, Enter a name and description to indicate to you who this template is
for.
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d) Select the ‘User Details’ tab.

e) Select a display name format from the drop down list.
f) Select a username format from the drop down list. If a format does not match your
requirements then you select ‘Custom’ to specify a custom format.
g) If you have selected ‘Custom’ for username format, enter a prefix and suffix, and select a
format. You can select ‘Custom’ again where you will have to complete the ‘Further
Customisation’ section. You can also enter “tags” in order to generate a specific custom
format. See the help file for a list of tags that can be used.
h) Select a conflict resolution if the username already exists.
i) Complete all other desired fields of the ‘User Details’ tab.
j) Select the ‘Member Of’ tab and add any desired groups for this type of user.
k) Select the ‘Password’ tab.
l) Specify what the new users’ password is going to be. ‘Date of Birth’ is used when importing
users and creating manually. The last option allows you to enter a predefined password that
will be common with all users who are created from this template.
m) Select any desired password options.
n) Select ‘Home Directory’ tab.
o) If you would like a home directory creating for the user then select ‘Create Home Directory’.
p) If selected, enter the server and the root path for the home directory. NOTE: the root path
MUST be how the server sees it, i.e. “C:\Users” and not “\\server\users” or “C$\Users”.
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q) You can specify whether to add the created user to the permissions of the created home
directory. Any inheritable permissions will be propagated.
r) You can also specify any additional permissions by clicking ‘Permissions’.
s) If you would like a share creating for the created home directory for the user then select
‘Create Share from Home Directory’.
t) If selected, select the format of the share.
u) Enter a share description.
v) Select how many users can access the share for ‘Max Users’.
w) You can specify whether to add the created user to the permissions of the created share.
x) You can also specify any additional permissions by clicking ‘Permissions’.
y) If you would like the created home directory to be added to the user account then select
‘Add directory to user account’ and select and specify a drive letter (optional).
z) Click ‘OK’ and enter a filename for this template.

7. Importing users from your MIS using the Extract Wizard
Firstly, ensure you have already created a connection to your MIS system and have at least one
template before proceeding.
a) Select the 'File' menu, then 'Extract...'

b)
c)
d)
e)

Select the MIS type.
If you would like to select which users to extract then select 'Customise Selection'.
Select 'Active Directory' in the 'Extract To' box.
Select ‘Test’ if you would like perform a test without making any changes to your Active
Directory network.
f) Select any of the other options which may be applicable.
g) ‘Move accounts to this site’ and ‘Move data to this site’ will only be available when you have
select “Single domain across multiple sites” in Options.
h) Click 'Next'.
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i)
j)
k)
l)
m)
n)
o)
p)
q)

Select the OU to extract the users to.
Select the database you would like to extract users from and click 'Next'.
Select which year you would like to extract, i.e. 'Year 7', and click 'Next'
If you select 'Admissions' for the year then you will need to select the admissions group and
click 'Next'.
Select the template you would like to use for the extracted users.
Select any actions to perform when certain events occur.
The users will now be extracted using the criteria you have selected.
If you have selected 'Customise Selection' then, from the list, select which users to extract
and click 'Next' to continue.
Alternatively, all the extracted users will be imported into Active Directory using the options
you have selected.

8. Importing users from your MIS using AutoImport
ActivMan AutoImport is a program which can be scheduled to automatically extract specified
users from your MIS and imported into your Active Directory. This would then remove the need
to manually perform the operation every time a new user arrives or an old user leaves. To do
this, follow these steps:
a) Either:
i.
From ActivMan, select ‘AutoImport’ from the ‘Tools’ menu.
ii.
From the Start menu, select ‘Configure’ from the AutoImport submenu of the
ActivMan menu group.
b) On the ‘MIS’ tab, select your MIS server. These MIS servers are taken from the main
application, so you will need to configure your server in the main application first.
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c) Select the 'Extract' tab.

d) Select the years and/or staff that you wish to extract from your MIS. If your MIS supports
'Admissions' then you can specify this too by selecting "[Admissions]" and clicking 'Select
Admissions'. Any custom years entered via Options in the main application will also be
shown here.
e) Select the 'Settings' tab.
f) You now need to enter each year that you wish to create accounts for, i.e. Year 7, Year 8,
etc.
i.
Click 'Add'
ii.
Select the year to be imported.
iii.
Select a template to be associated with this year. This template must be created
from the main ActivMan application. NOTE: Each year can use the same template if
necessary.
iv.
Select the Active Directory server from the list that this account will be created on.
v.
Browse for a desired OU on the specified server where these accounts will be
created.
vi.
Click 'OK' to save the year.
g) Repeat this process for all the years you are going to import.
h) Select the ‘Teaching Sets’ tab.
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i)
j)
k)
l)
m)

n)
o)
p)

If you would like to search your teaching sets in your MIS and create associated groups then
select ‘Yes’ for ‘Search for Teaching Sets’.
If you have selected ‘Yes’ to the above the then you will need to specify a location to create
the teaching groups.
Select from the drop down box what type the teaching groups will be when created.
Select the 'Options' tab and specify any desired settings.
For ‘single domains across multiple sites’ you are advised to select ‘Yes’ for ‘Remove user
from member groups’. Also check ‘Move accounts to this site’ and ‘Move data to this site’ if
desired.
Select the ‘Actions’ tab and select any actions to be performed when any desired events
occur.
Click 'Apply' to save the settings.
On successfully connecting to the server you are now ready to go. You can either 'Run Now'
or schedule this program to run at a future time.

NOTE
When moving data between sites the application may take a long time to complete, depending on
the size of the data to move. Therefore, if you “Run Now” you may not be able to close the
application until the data has been moved. This will also occur when running the application as a
scheduled task.

9. Scheduling AutoImport
To schedule the AutoImport application to run at any time you wish by create a standard
Windows scheduled task (this will vary depending on the operating system):
a)
b)
c)
d)
e)
f)

Open Windows Scheduler
Create a new task
Select the ActivMan AutoImport executable
ActivMan AutoImport does not require any additional arguments
Select the desired date/day/time for the schedule to run
Click 'OK' to create the schedule. It will now run at the specified date/time.

NOTE
As the application may take a long time to move user data between sites you MUST ensure that the
application should NOT be executed if the previous execution has not finished.
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